Config not Applying...
 
Notifications
Clear all

Config not Applying after Startup

5 Posts
3 Users
2 Reactions
205 Views
(@dontgetmewrong)
New Member Registered
Joined: 1 month ago
Posts: 2
Topic starter  

Hi Glenn and all others who can hopefully help me.

 

We used Desktop Info Version 3.0.0 from July 2021.

I noticed, there was a Problem with showing Win10 even it was Win11. 

So i updated to the latest version, which i deploy via GPO and i let it start via Autostart.

But now, it seems it doesnt recognize my config file at the start up. if i close the running service and start in manually (config file is in the same folder) it works. But not automatic at the start up.

 

What am i doing wrong?

 

thank you guys

 

br Patrick


   
Quote
Glenn
(@glenn)
Member Admin
Joined: 6 years ago
Posts: 1213
 

If you're starting via scheduler or something, you probably need to set the current work directory or put the ini file on the command line with the full path.


   
ReplyQuote
(@dontgetmewrong)
New Member Registered
Joined: 1 month ago
Posts: 2
Topic starter  

Thanky for your answer: that was it! 

Different behaviour, setting the work directory was not needed before.

Many Thanks!


   
Glenn reacted
ReplyQuote
 RJ45
(@rj45)
New Member Registered
Joined: 3 weeks ago
Posts: 1
 

I created a PowerShell script to install Desktop Info using Powershell that I can launch from our RMM tool at work. I just updated from the version released last fall and ran into this issue where Desktop Info was not using the desktopinfo.ini file when launched via the shortcut created by my script. It did however work normally if I created the shortcut manually in Windows Explorer. On comparing the properties for the shortcut files I found the shortcut I was creating via script was not setting the "Start in" property of the shortcut. I tweaked my script to include this and now it's working fine again.

Here is the code I am using to create the shortcut in case anyone else needs to do this. The change is the addition of the 4th line where I'm setting the Working Directory to the folder where the DesktopInfo64.exe file and desktopinfo.ini files are located.

$shellObj = New-Object -ComObject WScript.Shell
$shortcut = $shellObj.CreateShortcut("C:\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp\DesktopInfo.lnk")
$shortcut.TargetPath = "${env:ProgramFiles}\DesktopInfo3130\DesktopInfo64.exe"
$shortcut.WorkingDirectory = "${env:ProgramFiles}\DesktopInfo3130"
$shortcut.Save()

 

Anyhow thanks for the great software!

 

 

 


   
Glenn reacted
ReplyQuote
Glenn
(@glenn)
Member Admin
Joined: 6 years ago
Posts: 1213
 

Posted by: @dontgetmewrong

Thanky for your answer: that was it! 

Different behaviour, setting the work directory was not needed before.

Many Thanks!

I must fix that...

 


   
ReplyQuote
Glenn's Page