Link issue when zoo...
 
Notifications
Clear all

Link issue when zooming is activated

7 Posts
2 Users
0 Likes
118 Views
(@ne0-exe)
Active Member Registered
Joined: 2 months ago
Posts: 3
Topic starter  

Hi there,

I've configured desktop info on a few clients with a url to a ticket portal.
If the device has a monitor-zoom of (e.g.) 150% the url is not shown correctly. (see attached image)

I've set the following variable in the configuration file:
CONTROL=type:1,width:142,hover-color:#E4010C,text:IT Ticketsystem: ,display:xxxxxxxxx.de/support,uri: https://xxxxxxxx/support/xxxx/,style:b

How can I fix this issue by myself or is this a bug of the CONTROL variable?
Thanks in advance.

best regards,
Nicolas


   
Quote
Glenn
(@glenn)
Member Admin
Joined: 6 years ago
Posts: 1191
 
On ne0.exe said

Hi there,

I’ve configured desktop info on a few clients with a url to a ticket portal.
If the device has a monitor-zoom of (e.g.) 150% the url is not shown correctly. (see attached image)

I’ve set the following variable in the configuration file:
CONTROL=type:1,width:142,hover-color:#E4010C,text:IT Ticketsystem: ,display:xxxxxxxxx.de/support,uri: https://xxxxxxxx/support/xxxx/,style:b

How can I fix this issue by myself or is this a bug of the CONTROL variable?
Thanks in advance.

best regards,
Nicolas

Desktop Info is not handling zoom well at the moment. I recommend you switch off auto-scale in the [options] and, if needed, up the font size manually. I've revisited this very thing the last couple of days and the next release will work a little better.


   
ReplyQuote
(@ne0-exe)
Active Member Registered
Joined: 2 months ago
Posts: 3
Topic starter  

The auto-scale variable is not the solution.
If I set it to 0 the view is the same. If I set it to 1 the view is like 150% bigger.
I've no issue with the text size, this works fine. It's only the output of the CONTROL variable.

I'll wait for the next release.

Thank you!


   
ReplyQuote
Glenn
(@glenn)
Member Admin
Joined: 6 years ago
Posts: 1191
 
On ne0.exe said

The auto-scale variable is not the solution.
If I set it to 0 the view is the same. If I set it to 1 the view is like 150% bigger.
I’ve no issue with the text size, this works fine. It’s only the output of the CONTROL variable.

I’ll wait for the next release.

Thank you!

On ne0.exe said

The auto-scale variable is not the solution.
If I set it to 0 the view is the same. If I set it to 1 the view is like 150% bigger.
I’ve no issue with the text size, this works fine. It’s only the output of the CONTROL variable.

I’ll wait for the next release.

Thank you!

ok. It would appear the control is not scaling correctly. Depending on the font size, you can make the width bigger.


   
ReplyQuote
Glenn
(@glenn)
Member Admin
Joined: 6 years ago
Posts: 1191
 

The control is not measuring it's size correctly. I note that padding the display can help:

font-size=14
CONTROL=type:1,hover-color:#E4010C,text:IT Ticketsystem: ,display:    xxxxxxxxx.de/support  ,uri: https://xxxxxxxx/support/xxxx/,style:b 

   
ReplyQuote
(@ne0-exe)
Active Member Registered
Joined: 2 months ago
Posts: 3
Topic starter  

When I delete the width and padding the display, it shows only a clickable underline. Very confusing.

The width was set for normal use (100% zoom).

Our desktop set up is two 24" monitors and a dock. In this case the zoom is on 100% and the design is fine.
If you work only on your laptop screen, the zoom is in standard settings on 150%. (God bless the UHD graphics on small monitors..... not)
The only issue is, when you work with laptop monitor and zooming is activated.

So it's just a question of design.
Please do not take this topic too seriously.

Here is the complete ini file. Maybe it helps.

[options]
bottom=120
right=0
width=340
column1width=-1
centerv=0
centerh=0
fontface=Arial
font-size=12
cleartype=0
ssfontsize=12
formcolor=501010
transparency=100
contextmenu=0
allowdrag=0
offset=1
nav=0
language=english.ini
inimonitortime=10

[items]
HOST=active:1,interval:0,style:b,text:Hostname:,display:%1
NETWORKINTERFACES=active:1,interval:30,operstatus:1,iftype:6 71,text:IP Address:,display:%8,style:b
COMMENT=text:,hidden:0
CONTROL=type:1,width:142,hover-color:#E4010C,text:IT Ticketsystem: ,display:johndoe.de/support,uri: https://johndoe.de/servicedesk,style:b
TEXT=active:1,interval:60,text:IT Hotline:,display:+49 (0) 1234 4567 -1111,style:b


   
ReplyQuote
Glenn
(@glenn)
Member Admin
Joined: 6 years ago
Posts: 1191
 

My CONTROL code needs some work. I'll have it sorted out in the next release.


   
ReplyQuote
Glenn's Page