I install the recom...
 
Notifications
Clear all

I install the recommended drivers, then I have to use system restore to get back into my computer

3 Posts
2 Users
0 Reactions
250 Views
(@the_unforgiven)
New Member Registered
Joined: 3 weeks ago
Posts: 2
Topic starter  

As the title says, I install the recommended drivers, then I have to use system restore to get back into my computer.

It has been happening for a few updates.  I keep forgetting because of my f...... memory.

I have included a picture of what it installs/stuffs up my comp.

My specs are EVGA X570 DARK mother board

5900X CPU

7900XT Hellhound GPU

32 GB Corsair Dominator RAM

Is there a way to tell which one is making my comp not boot up, apart from going through them one by one?

Thanks for the help   😎   and if you need more info from me, just ask


   
Quote
Glenn
(@glenn)
Member Admin
Joined: 6 years ago
Posts: 1222
 

See the frequently asked questions.

 

Stop installing drivers for the sake of it.


   
ReplyQuote
(@the_unforgiven)
New Member Registered
Joined: 3 weeks ago
Posts: 2
Topic starter  

It tells me that it needs them drivers

How do I know which ones are for the sake of it or the ones I need?

As I just did a Windoze 10 Pro install.  I have the latest BIOS & the latest drivers from EVGA,

so why are the 'for sake of it drivers' showing?

What about the rest of the people who use your software that doesn't have the experience that I do?

Your answer is very vague, you don't say which drivers should not be installed & which ones should.

But if people use your software & get recommendations to install drivers, does that mean they should ignore them?

So what is the use of your software then if we ignore your driver recommendations!


   
ReplyQuote
Glenn's Page