Wrong font-size after startup

Forums Desktop Info Wrong font-size after startup

Tagged: , ,

Viewing 9 reply threads
  • Author
    Posts
    • #5024
      TheBoneZoneTheBoneZone
      Participant

      Hi,
      first, the expected Metadata:

      Windows: Windows 10 20H2
      Desktop Info: 3.3.1

      Snippet from config.ini: (complete options block)

      The Problem:
      I put a link of Desktop Info in the autostart folder of Windows for automatic startup. The program comes up with the wrong font-size. I guess it must be 14 or 16. Too big to fit. If i resave the desktopinfo.ini (inserting or deleting a blank) it reconfigure to the expected font-size of 11. Thats a pesky workaround.
      I work with a external Monitor and the Notebook display.

      Any help/tips are really appreciated.

    • #5025
      TheBoneZoneTheBoneZone
      Participant

      PS.: I tried the commented options active/inactive no change of the behaviour.

    • #5026
      GlennGlenn
      Keymaster

      That’s a curious issue. Which startup folder are you using? Have you tried starting it from Task Scheduler?

    • #5027
      TheBoneZoneTheBoneZone
      Participant

      Indeed curious and annyoing.

      I used [win] + r -> shell:startup
      that brings up the folder:
      C:\Users\[username]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup

      I will explore the Task Scheduler way and report the outcome.

    • #5028
      TheBoneZoneTheBoneZone
      Participant

      The results after some further tests.

      Using Task Sheduler = same result.

      I can reproduce it on every restart of the DesktopInfo Process. It comes up with the wrong font-size after saving the ini file again – redraw to correct font-size.

      I have recorded it, with debug option on. But i fear there is nothing unusal to see?

    • #5029
      TheBoneZoneTheBoneZone
      Participant

      trying logfile as zip…

      Attachments:
    • #5034
      GlennGlenn
      Keymaster

      It is related to font scaling on a high dpi monitor. I notice your monitor is set to 125% which causes the font size to scale up. This is how it is supposed to work. I think the actual bug is that it scales back down again when you save/reload, it shouldn’t do this, it should remain scaled up.

      If you need it to look the same as it would on a 100% monitor then you probably want to disable automatic scaling, page 14:

      [options]
      auto-scale=0

    • #5036
      TheBoneZoneTheBoneZone
      Participant

      That was it. If i set the option you mentioned it works.

      Reading the manual carefully could help. I read it, but oversee this option, or didn´t bring it together with my issue.

      Anyway, thank you for your support. Great tool, keep it running.

      PS.: To my complete luck, i looking for an option to show the acutal outgoing tcp connections.
      aka: netstat -f – Would be the CMD item the right way to realize it?

    • #5037
      GlennGlenn
      Keymaster

      yes. be careful, this command can take a long time to return if using the -f switch.

      You can filter on the external host by using the “find” pipe command:

    • #5063
      TheBoneZoneTheBoneZone
      Participant

      I tried it out. But it seems thats not a practical way. As you said it took a long time to execute the command. Meanwhile the charts are frezed and it looks like the Monitor hangs.

      Its obviously a problem of the netstat command and it implementation. (Not performance trimmed)

      A solution might be, if the Montior load the CMD item asynchronously. But i am happy as it.

Viewing 9 reply threads
  • You must be logged in to reply to this topic.
Glenn's Page