Killer E2400 Driver

Forums Snappy Driver Installer Origin Killer E2400 Driver

Viewing 3 reply threads
  • Author
    • #5869

        I have a motherboard that has an on-board Killer Networking E2400. Windows installs its own driver with version signed by Microsoft, but I updated it manually a while back with the a driver I downloaded from Rivet networking before they were bought by Intel. The driver I installed is version

        I’m trying to diagnose a network related annoyance, and I decided to check for an updated driver. I kept a backup of that driver because I haven’t been to find drivers for this card since Intel bought Rivet Networking. On Intel’s driver page, selecting the E2400 takes you to the download page for the Killer software, but it says it doesn’t include a driver for this card.

        I found SDIO and downloaded it. SDIO detects a better matched driver, but Windows refuses to use it. I tried uninstalling the device and let Windows re-install its default driver. I’ve tried manually extracting the driver from the driver package SDIO downloads, and performing a manual update from Device Manager, but Windows tells me the best drivers for my device are already installed.

      • #5886

          What does that mean, “Windows refuses to use it”?

          • #5895

              After installing the above “driver”, SDIO still shows the driver it just installed along a new one with the same name and different icon, which is the actual Killer Networking Software (screen shot attached). I did try installing that, but Windows is still using the Microsoft driver. After installing both of those Killer Networking Software packages, SDIO still shows that first Killer Networking Software as as an updated driver available, plus now I have a bunch of extra services and software I can’t use installed.

              I tried using device manager to manually update the driver, and it says I’m already using the best driver for the device. I extracted the files from the SDIO driver package (DP_LAN_Others_23000.7x), and if I do the “have disk” method and browse to the files I extracted, Windows says its not a compatible driver for this device.

              I used DriverStore Explorer to remove the stuff that was installed since I don’t want it.

              I bet it’s probably the same software that is on Intel’s site that contains the Killer Networking Software, which says it does not contain a driver for this card.

              Looking at the files, the first part it installs looks to be some sort of extensions for the second part that is the actual Killer Networking Software, not an actual driver because it’s just a .inf and .cat file. The KillerNetworkingExtension.inf does have the Killer E2400 listed in it, but the Killer Networking Software still doesn’t see it.

          • #5894

              Killer Networking IS NOT the driver. It’s part of Killer’s software suite (which I don’t want). I also have Killer NIC and latest one is (just open below options) – I haven’t noticed anything relevant when upgrading so I am using default Microsoft driver

              • #5897

                  Well not exactly. The first one that shows up has a gear icon is not the software. After installing that and refreshing, SDIO will now show another Killer networking Software available with a different icon (see screenshot posted in reply above), which is the Killer Bloatware, which I also don’t want.

                  I also went back to the Microsoft driver to see if it solved the issue I was having. It didn’t, so I went back with the Rivet driver.

                  I thought I had all of my drivers up to date, but SDIO did find some newer ones that I don’t see on manufacturers driver pages. I like to keep my drivers up to date, and it is getting tiresome trying to hunt down drivers on various manufacturer websites, so SDIO is something I’m going to keep around.

                  Anyway, after updating drivers, I’m still having a weird issue that’s bothering me. I don’t think the problem I’m having is driver related or the card itself, but I figured it was worth a try. Since you have the same card maybe you can tell me if you’re having it too?

                  When I download files from my browser, it always caps out at 1.2MB/s or 2.4MB/s. I always thought it was the site(s) I was downloading from doing it because downloads through things like Steam or GOG Galaxy max out my connection. A few weeks ago I was downloading a large mod for a game, and it was only doing 1.2MB/s. That was going to take a while, so I remote desktoped into another PC have and was going to let it download there. On that PC it downloaded at the full speed of my internet connection.

                  I have Firefox on both PCs, but I’ve tried other browsers. Like I said, it only happens when downloading through a browser (any browser). It doesn’t matter what site either, it’s consistently either 1.2MB/s or 2.4MB/s. Downloading through other things, game clients like Steam, Galaxy, for example will max out my connection.

              • #5898

                  My NIC card isn’t exactly the same. Mine is E2200 (just from the top of my head). If you are downloading via http, your mileage may vary. Just a wild guess. When I am downloading from Steam, for instance, I get full 70-80MB/s.

                  Some sites may have a capped maximum download speed.

              Viewing 3 reply threads
              • You must be logged in to reply to this topic.
              Glenn's Page