Issue with font-quality option

Forums Desktop Info Issue with font-quality option

Viewing 9 reply threads
  • Author
    Posts
    • #4503
      IH
      Participant

      Hi Glenn,

      Many thanks for a great tool, and forgive me if it’s me doing something wrong.

      Running Windows 10 Pro 20H1 64bit.

      My laptop has a 1920×1080 display, and Windows recommends (and is set to) 125% ‘for scale and layout’ in Display settings. Since v3.2, no matter which value I choose in my ini file for ‘font-quality’, the text in Desktop Info doesn’t change quality, and is stuck on (I think) anti-aliased. However, if I change the scaling to 100% before I launch Desktop Info, the font-quality value is respected and I am able to choose between non-antialised (my preference), anti-aliased and cleartype. Also, if, after launching Desktop Info with the scale on 100% and then manually changing the scale to 125% or even 150%, I am able to change the font-quality value and watch the font quality change on-the-fly in I set the inimonitortime nice and short. The font-quality preference worked fine for me in v3 and v3.1.

      Many thanks,
      IH

    • #4506
      Glenn
      Keymaster

      Thanks for the bug report. I’ll look into it.

      The scaling issues continue…

      • This reply was modified 1 month ago by Glenn.
    • #4508
      Glenn
      Keymaster

      Seems to be better now. At least it’s working for me. I remain skeptical tho 🙂

      Look for v3.2.2 soon.

      • #4541
        IH
        Participant

        Hi Glenn,

        Sorry to be a pain, just to let you know unfortunately no difference for me in v3.2.2, still the same scenario – perfect if launched at 100% and scale then changed, but if launched when scale not at 100%, the text has the same anti-aliased quality no matter what I choose for font-quality.

        Thanks,
        IH

    • #4545
      Glenn
      Keymaster

      I did this test with v3.2.2 on Win 20H2, scaling set to 150%.

      • #4573
        IH
        Participant

        Hi Glenn, sorry for the delay in getting back to you.

        I’ve attached a (very rough) pasted image of what I see at 100% scale and 150% scale (to compare to your previous image, although the recommended for my laptop is 125%)

        I’ve stripped my .ini file right back in case I was doing something wrong which I couldn’t see, but for me the issue remains:

        [options]
        bottom=0
        right=12
        width=405
        column1width=130
        font-face=Tahoma
        font-size=16
        font-quality=3
        inimonitortime=5
        ignore-setting-change=0
        transparency=100
        nav=0

        [items]
        COMMENT=Tahoma,16,font-quality=3

        One extra thing I’ve noticed, if I run DesktopInfo when my scaling is not 100%, the first time it displays, the font size looks as if it is about 50% of its normal size. Strangely (I kept the ini monitor time short to test) if I resave the ini file without any change whatsoever, the text then sizes up to (I presume) the font size specified on the refresh.

        Thanks,
        Ian

        Attachments:
        • #4576
          Glenn
          Keymaster

          it seems we’re getting different results. I’m not sure what comes next.

    • #4581
      IH
      Participant

      Hi Glenn, as a glutton for punishment I’ve upgraded my machine to Windows 11 to have a look around, unfortunately still the same behaviour. I note that it works for you on 20H2 (on Windows 10 I was on 21H1) so if time allows I’ll try and put 20H2 on the machine and see how it gets on. Thanks.

    • #4584
      rtruss
      Participant

      I am seeing this , the image marked ‘expected’ is what I am seeing on my virtual device and the other one, marked surface and full screen shot, is what I am seeing on my daily driver. Microsoft Surface. Windows 11 Insider Preview on DI 3.2.2. I still need to update my vm to win 11 to see how it goes. When I try to change scale on my surface the blue buttons change size but the text does not and the letters on the edges get cut off. My surface is one of a few so I am able to move forward with all my devices for now. Just wanted to relay what I am seeing also.

      Attachments:
      • #4621
        Glenn
        Keymaster

        Fingers crossed, I have this solved.

    • #4586
      rtruss
      Participant

      here is the pic of my surface di output

      Attachments:
    • #4593
      IH
      Participant

      Hi, me again. I flattened my machine, and tried both Windows 10 x64 20H2 and 21H1, and Windows 11 x64 21H2 (all via wiping the hard drive and installing direct off the microsoft ISOs) and unfortunately they all exhibit the same behaviour. The laptop has a 1920×1080 display and an bog-standard Intel UHD graphics card. I tried them all on first boot (before the proper graphics driver was installed) and after the proper driver was installed.
      It all works OK on v3.1.0.4074 (even on Windows 11!), it is, for me at least, v3.2.0.4119 and above where I see the font-quality issue. Also, as explained above, on v3.1, the fonts are of a certain point size from the first time desktopinfo runs, and the only thing that changes that is changing the font size in the .ini, as expected. For me on v3.2 and above, on first run on desktopinfo, the size is much smaller than expected, and then if I resave the ini file (even with absolutely no changes) the size immediately increases. Please excuse me if I’m not being clear – if (work) time allows I’ll try and capture a couple of screenshots if you need them.
      Thanks Glenn for an excellent tool, please don’t think my ramblings take anything away from my appreciation of it.

      • #4612
        Glenn
        Keymaster

        Thanks for the update. I’ll keep working on it…

    • #4622
      Glenn
      Keymaster

      I found the broken font quality code and fixed. Look for v3.2.3 shortly…

    • #4625
      rtruss
      Participant

      That is exciting. My team keeps hounding me to get this deployed to our Azure based Modern workplace devices. 🙂

Viewing 9 reply threads
  • You must be logged in to reply to this topic.
Glenn's Page