if not working as expected with control

Forums Desktop Info if not working as expected with control

Tagged: 

Viewing 2 reply threads
  • Author
    Posts
    • #5602
      Ryan DrownRyan Drown
      Participant

      I am having a problem with “if”. In my code below, the control line runs no matter what the if says. I have tried moving to be the very next line, but it still always displays the button. the if works fine with my text line either directly after the if, or after the control. I have seen lots of examples similar to what I am doing but no one else seems to have this problem.

      if=value1:%domaintime%,comp:ge,value2:21,eval:2
      text=active:1,font-size:120%,color:0000FF,Text:Warning: Your computer has not|made contact with the Purdue network|for %domaintime% days. Please connect to the Purdue|VPN and leave your machine on overnight|to allow software and security updates to|apply.
      control=text:,type:0,display:Launch Purdue VPN,wide:1,uri:”C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\vpnui.exe”

      Thank you,

      Ryan

    • #5603
      GlennGlenn
      Keymaster

      The TEXT is causing the left column width to grow. You can either set a fixed column width in the options or set wide:1 and use display: instead of text:

      text=font-size:120%,color:0000FF,wide:1,display:Warning: Your computer …

      or use the COMMENT item:

      comment=font-size:120%,color:0000FF,display:Warning: Your computer has …

      which is essentially the same thing.

      The code around the IF / CONTROL items is not perfect (shock!). The IF doesn’t evaluate on startup causing the CONTROL to display and during the normal cycle when the IF does evaluate, it fails to switch off the CONTROL.

      Add “onload:1” to the IF item to force it to evaluate during startup but that won’t help once the condition changes.

      I’ll raise an issue to fix that bug.

    • #5604
      Ryan DrownRyan Drown
      Participant

      I tried adding “,onload:1” to the end of my if. That did prevent the control from running, but it also causes the if to be false regardless of the evaluation, so neither the text or control ever show up with “,onload:1” added. I can just turn off the control until a fix is released.

      Thank you,

      Ryan

Viewing 2 reply threads
  • You must be logged in to reply to this topic.
Glenn's Page