Error: install : Nothing selected

Forums Snappy Driver Installer Origin Error: install : Nothing selected

Tagged: ,

Viewing 12 reply threads
  • Author
    Posts
    • #3082 Reply
      AvatarDan

      First off, SDIO is wonderful – very grateful for such a simple and effective product. Thanks Glenn!

      I’m attempting to update via script for the first time. If I open SDIO on the target computer, there are approximately 10 updates needed – all show “Updated driver available” or “Updated driver available which is also more optimal”. When I execute the command calling oakslabs-test.txt (with enableinstall off or on), the end of the output reads:

      echo Downloading and Installing drivers...
      0 drivers selected
      Error: install : Nothing selected0 drivers installed, 0 drivers failed.

      Is there something that I’m missing in the select command? I’ve tried running the script with “newer” in place and in addition to the “missing better” flags with no difference. I’ve also tested with x64 and x86 of versions of R710 and R712. Thanks in advance for any assistance!

      0
    • #3083 Reply
      GlennGlenn
      Keymaster

      It appears the select command is not working correctly. I’ll look into it.

      0
    • #3086 Reply
      GlennGlenn
      Keymaster

      I think I found it. Look for a release shortly.

      1+
    • #3090 Reply
      AvatarDan

      Thanks Glenn! Getting closer but still not having success. Output now shows a number of drivers but still nothing selected:

      echo Downloading and Installing drivers...
      Select: 34, 0
      0 drivers selected
      Error: install : Nothing selected0 drivers installed, 0 drivers failed.

      Out of interest, if I open the app on the target computer, it shows only 7 updates for the missing & better flags. How does the 34 in the script correspond to the 7 in the GUI, or is that also perhaps a bug?

      0
    • #3091 Reply
      GlennGlenn
      Keymaster

      34 is the bitmapped representation of the Missing and Better checkboxes where Missing = 2 and Better = 32. 0 is the number of driver pack filters specified.

      The output is showing the select command arguments going in and the results.

      Are you using the oakslabs-test.txt script from the zip file or a modified version? If modified, can you post your script. I tested quite a bit on that script and it’s all working here.

      0
    • #3095 Reply
      AvatarDan

      Thanks again for your reply Glenn and sorry for the delayed response on my end. In comparing the scripts, I had mistakenly (?) commented out the “get indexes” line thinking it to be not necessary since we have already pulled local copies of all applicable drivers to our network. When I reactivated the lines, the script does manage to complete but takes noticeably longer than when updating by opening the app directly. The delay occurs at the “{torrent_start” line. Is there some way to determine whether the script is pulling from our local repository or trying to torrent the downloads from outside the network? We also don’t have port 50171 explicitly open in our firewall – could that have some impact?

      0
    • #3097 Reply
      GlennGlenn
      Keymaster

      Please read the section in the manual regarding scripts. Particularly the part that says:

      “The config file is ignored and all command line arguments prior to -script are ignored. Therefore, all configuration is done within the script. Make no assumptions except the following defaults.

      Defaults:
      No log file
      No snapshot
      Driver directory: “drivers”
      Logs directory: “logs”
      Indexes directory: “indexes”
      Extract directory: “%temp%\SDIO”
      Verbose: nothing
      Torrent port 50171″

      You haven’t posted your script so I will assume you haven’t set the config in the script. Update your script to account for your configuration. If that doesn’t work then post your script here and I can look into it further.

      0
    • #3098 Reply
      AvatarDan

      Here’s our script:

      #
      # Snappy Driver Installer Origin
      #
      # Title: Install Updates
      # Author: Glenn Delahoy
      # Description: Installs required drivers.
      # Notes: Test mode by default. Set 'enableinstall on' to make it live.
      #
      
      echo ==============================
      echo Snappy Driver Installer Origin
      echo       Install Updates
      echo ==============================
      echo
      
      echo Initialising...
      verbose 384
      logging on
      enableinstall off
      init
      checkupdates
      echo Getting latest indexes...
      get indexes
      echo Creating restore point...
      restorepoint PCA SDIO Driver Installation
      echo Downloading and Installing drivers...
      select missing better
      install
      reboot ifneeded
      end

      App is running from: \\server\SDIO\SDIO_x64_R714.exe
      Script is located in: \\server\SDIO\scripts
      Drivers are saved in: \\server\SDIO\drivers
      Indexes are saved in: \\server\SDIO\indexes

      Apologies if I wasn’t interpreting the defaults properly. If they are not relative to the EXE location, should I be specifying the full path to both drivers and indexes? Thanks as always!

      0
    • #3119 Reply
      GlennGlenn
      Keymaster

      Ok, you’re running it from a network share. I’ve tested this scenario and that has uncovered some issues. I’ll deep dive into the code over the coming week and see what emerges.

      0
    • #3124 Reply
      AvatarDan

      Thanks again, Glenn – much appreciated! Let me know if I can test in any way (I presume through this board you have access to my email address).

      0
    • #3142 Reply
      GlennGlenn
      Keymaster

      I think I’ve got it. I’ll do some testing over the next few days. I might get you to test it before I make it public.

      0
    • #3146 Reply
      GlennGlenn
      Keymaster

      Nope, I don’t got it. There’s some problem with running it from a UNC path that I can’t pin down. I’ve spent way too much time on it without resolving it so I’ll have to let it go for now.

      I’ve made a bunch of changes to the code which may or may not help you with your issue. I’ve successfully run it over a mapped drive without any path overrides in the script but it doesn’t work over a UNC network path.

      So the procedure would be to run it locally to download the latest driver packs and update the indexes. When you want to run it over the network, set up a mapped drive to the directory where the .exe is, make that the current working drive and directory then run it.

      @echo off
      net use U: “\\server\sdio”
      U:
      cd \
      sdio.exe -script:scripts\install.txt
      c:
      net use U: /delete

      I guess you could put this batch file on the server and run *that* over a UNC path.

      *** LOOK HERE ***
      I haven’t tested this on v1.6.4. I don’t know if this works or not (hint: I don’t care). I’ve tested it on v1.6.5 and it does work.

      v1.6.5 sometime today.

      1+
    • #3154 Reply
      AvatarDan

      Glenn – thank you so much for your efforts and once again for a great program. I’ll definitely be testing the batch script (with 1.6.5!) and will find a way to make it work if things are not set out of the box. Sent a small donation your way earlier in appreciation. Have a wonderful day!

      1+
Viewing 12 reply threads
Reply To: Error: install : Nothing selected
Your information:




Do NOT follow this link or you will be banned from the site!