[Bug] executing DI from script in different directory – FILECONTENTS1

Forums Desktop Info [Bug] executing DI from script in different directory – FILECONTENTS1

This topic contains 1 reply, has 2 voices, and was last updated by Glenn Glenn 3 weeks, 2 days ago.

  • Author
    Posts
  • #1585 Reply
    Avatar
    ntech2
    Participant

    Hi,
    just reporting what seems to be a bug.

    When running DesktopInfo.exe from a script or command line where the current working directory is not the same as the location of txt files used with FILECONTENTS1, the files will not load.

    FILECONTENTS1=active:1,interval:1,text:test,file:test.txt

    To reproduce:
    1) Place DesktopInfo.exe and DesktopInfo.ini and Test.txt in a folder(i.e. C:\temp). Configure the ini file to use FILECONTENTS1 to show content of test.txt.

    2) Open CMD, use any command to run an exe, like

    start C:\temp\desktopinfo.exe

    3) The contents will not be displayed.

    Workaround1: End DI process, in CMD/script use CD to change directory to C:\temp and start the exe again. It will display correctly now.

    Workaround2: Use the full path to txt file and it will work fine.

    Maybe not a big deal but changing it so DI uses the location of the exe for current dir might be better, if possible.

    0
  • #1588 Reply
    Glenn
    Glenn
    Keymaster

    I would say that you should specify the full path but I’ll add some code to search the application path.

    0
Reply To: [Bug] executing DI from script in different directory – FILECONTENTS1
Your information:




Do NOT follow this link or you will be banned from the site!