[BUG] Command-Line autoinstall not working

Forums Snappy Driver Installer Origin [BUG] Command-Line autoinstall not working

Viewing 2 reply threads
  • Author
    Posts
    • #5731
      Simon RädlerSimon Rädler
      Participant

        Hello!
        I would like to integrate SDIO into my windows automation setup.
        I’m using SetupComplete.cmd after windows is installed unattended to install the drivers using SDIO.

        As of today, I started the application by calling the SDIO_auto.bat and further selected all drivers not installed and pressed install.

        Then I thought about doing it automatically and found the -autoinstall option.
        In combination with the -autoclose option it is what I’m searching for.

        1. Start the application
        2. Install missing drivers
        3. Close the appliation

        I tried it with the following command: “START /wait /b cmd /c SDIO_auto.bat -autoinstall -autoclose”
        I also tried to do it manually in a CMD by calling “SDIO_x64_R749.exe -autoinstall -autoclose”
        The latter produced the following output: https://pastebin.com/LL8RYdiz

        I could read out of the log file that no driver could be found in the index. So I also tried this: “SDIO_x64_R749.exe -reindex -autoinstall -autoclose”
        The result is here: https://pastebin.com/mM2eqdcH
        SNP-File: https://pastebin.com/KSBqfqy1

        So I cannot figure out, what I’m doing wrong.

        May I ask you to help me?

        • This topic was modified 1 week ago by Simon RädlerSimon Rädler.
        • This topic was modified 1 week ago by Simon RädlerSimon Rädler. Reason: Upload was not possible so I used pastebin
      • #5734
        GlennGlenn
        Keymaster

          do you have any drivers downloaded yet? the logs indicate a failure to download the update torrent. when you run SDIO normally it should attempt to check for updates. make sure this is working.

        • #5735
          Simon RädlerSimon Rädler
          Participant

            No, I would like to provide a fresh SDIO without Index or Drivers offline.

            Yes, in manual mode, it downloads from the torrents as expected.

            • #5736
              GlennGlenn
              Keymaster

                I don’t know that I’ve ever used that command line stuff. Have you looked into the scripting yet? Check the manual for details.

                In any case, you’ll need at least indexes available before you get any meaningful results.

                • #5738
                  Simon RädlerSimon Rädler
                  Participant

                    I tried it with index available.
                    The result is, that it tries to install but only uses local files.
                    Required files are not downloaded using torrent.

                    Even with “-autoupdate -autoinstall -autoclose” it is not working

                    I think the command-line is broken. Can you fix this?

            Viewing 2 reply threads
            • You must be logged in to reply to this topic.
            Glenn's Page